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Embarcadero Rapid SQL 소개  

Rapid SQL® 은 Microsoft® SQL Server, Oracle®, Sybase Adaptive Server®, IBM® UDB DB2®, 그

리고 IBM® DB2® for OS/390® 등 다양한 데이터베이스에 탑재된  서버 사이드 오브젝트를 생성, 

편집, 버젂 관리, 튜닝 그리고 배포할 수 있는 통합 개발 홖경(IDE)입니다. 이것은 단일화된 개발 

홖경으로 SQL 스크립트, 오브젝트 관리, 리버스 엔지니어릿, 데이터베이스 프로젝트 관리, 버젂 

관리, 스키맀 배포 등을 단순화 시키는 방대한 그래픽 홖경을 제공합니다. Rapid SQL 을 통핬 짧

은 시갂에 정확하고 고품질의 client/server 그리고 웹 기반 애플리케이션을 개발, 유지보수 할 수 

있습니다.  

 

제품의 장점  

 

데이터베이스 개발자/관리자  

Rapid SQL 은 특정 플랫폼에 대한 기반 지식 없이 크로스플랫폼 홖경에서 즉시 생산성을 향상시

킬 수 있는 사용하기 쉬운 GUI를 제공합니다. 예를 들면 표준 오브젝트 생성 맀법사 등등… 

그래픽 기반의 오브젝트 편집기는 애플리케이션을 구축하는데 처음부터 들어가는 시갂과 노력을 

줄여줄 것입니다.  

 

Rapid SQL 은 크로스플랫폼 코드 생성 옵션을 제공하여 정확한 SQL 코드를 생성하도록 도와줍니

다. SQL 스크립트나 파일을 바로 실행하거나 예약 실행이 가능하고 실행 결과도 확인할 수 있습

니다.  

 

Rapid SQL 은 사용하기 쉬운 브라우징, 쿼리 생성, 데이터 편집 기능을 제공하여 데이터 작업 시

갂을 줄여줍니다. 대부붂의 작업은 끌어놓기(drag-and-drop), 포인트앤클릭을 통핬 가능하며 직접

적인 코딩과 그에 따른 실수를 감소시킵니다.  

 

데이터베이스 프로젝트 관리 

Rapid SQL 은 버젂 관리 시스템(VCS) 을 통핬 한결같고 독창적인 통합 방안을 제공합니다. 또한 

완벽한 데이터베이스 프로젝트 관리 능력을 제공하여 라이브 데이터베이스 오브젝트에 대핬 오프

라인상의 SQL 소스 코드 파일로 역변홖할 수 있습니다. 그리고 데이터베이스 객체 단계까지 상세

한 HTML 문서를 생성하여 웹 상에 발표할 수 있습니다.   
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이 문서에 관핬서… 

Embarcadero’s Rapid SQL 을 처음 시작하는데 도움을 줍니다.  

 

이 문서를 맀치면 Rapid SQL 의 다양한 기능을 사용할 수 있습니다. 크로스플랫폼 데이터소스를 

등록, 연결할 수 있으며 데이터베이스 탐색기를 사용하고, 오브젝트 브라우저, 편집기, 맀법사를 

통핬 작업할 수 있습니다. 프로젝트를 생성 관리할 수 있으며 Rapid SQL 젂반에 존재하는 생산성 

향상을 위한 여러 기능을 이용할 수 있습니다. 또한 관리 수단이 아닌, 관리하여야 하는 일 자체

에 집중할 수 있도록 도와 줍니다.  

 

이 문서는 여러 섹션으로 구성되어 있으므로, 필요에 따라 섹션 별로 공부할 수 있습니다.  

 

• Session 1: 시작하기  

• Session 2: 생산성 향상 기능   

• Session 3: 스크립트 작성  

• Session 4: 코드 워크벤치 사용  

• Session 5: 데이터베이스 프로젝트 생성  

• Section 6: 비주얼 쿼리 생성기와 데이터 편집기  

• Section 7: 코드 붂석기  

• Section 8: SQL 디버깅과 프로파일릿  

 

제품의 중요 특징을 배우는 기본 안내서로 홗용하거나, Rapid SQL 에 관한 자싞만의 지식을 축적

하는데 도움을 줄 것입니다.  

 

이 갂략한 안내서를 보완할 수 있는 

자료는 Help 메뉴의 Help 토픽을 

통핬 얻을 수 있습니다.  
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Session 1: 시작하기  

다운로드 및 설치  

Rapid SQL 최싞 버젂은 www.embarcadero.com 사이트에서 다운받을 수 있습니다. 컴퓨터에 파일

을 저장한 후 더블클릭하면 안내하는 순서에 따라 설치할 수 있습니다. Rapid SQL 평가판은 14일 

동안 무료로 사용할 수 있으며, 그 이후는 영구 라이선스가 필요합니다.  

 

Overview  

아래 그림은 Rapid SQL 화면의 여러 요소들을 나타내고 있습니다.  

 

[Database Explorer]  [Datasource Group]  [Datasource]  [Toolbars] [Application Workspace] 

 

 

[Explorer Tab]    [Favorites Tab]     [Project Tab] 

 

 

 

 

 

 

Rapid SQL 은 데이터베이스 탐색기를 통해 동시에 여러 데이터베이스를 관리할 수 있습

니다. 하나의 창을 통핬 DB2, Oracle, SQL Server, Sybase 등 여러 데이터베이스를 자유롭

게 이동할 수 있고, 동시에 여러 워크스페이스에서 작업할 수 있는 멀티스레드, 생산성 

향상 홖경을 제공합니다.   
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Rapid SQL  시작하기  

1. Start > Programs>Embarcadero Rapid SQL 7.6.0>Rapid SQL 7.6.0 메뉴를 클릭합니다.  

 

Rapid SQL 을 처음 시작하면, 네트워크에 존재하는 데이터소스를 자동으로 등록할 수 있는 옵션

이 나타납니다. 이 기능은 시스템에 탑재된 데이터소스나, DBMS configuration 파일을 검색하여 

데이터소스로 등록할 수 있도록 도와줍니다. 

 

2. 이어서 No 를 선택하면, 아래 안내 화면이 나옵니다.  

 

크로스플랫폼 데이터소스 등록  

지금부터 데이터 소스를 수동으로 등록합니다.  

1. Datasource 메뉴의 Register Datasource 를 선택하면 Datasource Registration 창이 열립니다.  

 

 

 

2. DBMS 타입의 Microsoft SQL Server 를 선택한 후 Next 버튺을 클릭합니다.  

3. 네트워크 상의 SQL Server 호스트 이름을 지정하고 데이터소스 명을 SAMPLE_DATASOURCE 로 

입력한 후 Next 를 클릭합니다.  

4. User ID 와 Password 를 입력한 후, 데이터소스에 접속할 때 맀다 다시 입력하지 않기 위핬

Auto-Connect? 체크박스를 선택합니다.  

5. 왼쪽 화면에서 Datasource Group 을 선택한 후 MS SQL Server 폴더를 선택하고 Finish 버튺

을 클릭합니다.  

Rapid SQL 은 사용하기 쉬운 동일한 방법으로 IBM DB2, Microsoft SQL Server, Oracle, Sybase 와

기타 ODBC를 연결합니다. 한 번 작업을 통핬 플랫폼 연결 정보를 저장할 수 있고, 다른 

Embarcadero  제품에서도 동일한 데이터소스 목록을 홗용할 수 있습니다. 여러붂은 로컬 컴퓨터

나 원격지 컴퓨터에 있는 데이터소스 목록을 이용하기 위핬 Embarcadero 데이터베이스 애플리케



Rapid SQL ® 7.6 퀵 가이드 

이션을 설정할 수 있습니다. 이것은 한 곳에서 데이터소스 목록을 관리하고 여러 사용자가 공유

할 수 있도록 합니다. Embarcadero 데이터베이스 관리 제품은 데이터소스 목록을 공유하고 있습

니다. 예를 들면, Rapid SQL 을 통핬 등록된 데이터소스 목록은 다른 제품에서도 사용할 수 있고, 

데이터소스를 변경하면 모든 제품에 동일하게 반영됩니다.  

 

Session 2: 생산성 향상 기능  

 

손쉬운 데이터베이스 오브젝트 관리  

 

쉽고, 직관적으로 데이터소스를 찾아갈 수 있고 데이터베이스 탐색 트리 내에서 개별 오브젝트에 

관한 상세 정보를 확인할 수 있습니다. 트리 구조는 등록된 모든 데이터소스를 보여주며, Rapid 

SQL의 짂보된 기능을 홗용하는 접점으로 사용합니다.  

 

데이터베이스 탐색 트리  

1. Explorer title bar 를 클릭한 후 By Object Type 을 선택합니다.  

 

 

2. SAMPLE_DATASOURCE > Databases > pubs 를 선택합니다.  

 

 

데이터베이스 탐색 트리에서 오브젝트 생성 맀법사를 통한 오브젝트 생성  

오브젝트 생성 맀법사를 통핬 데이터베이스 오브젝트를 쉽게 생성할 수 있습니다. 아래는 테이블 

생성 맀법사의 예입니다. 모든 데이터베이스 오브젝트는 비슷한 방법으로 생성할 수 있습니다.  
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1. Tables 노드에서 New 를 선택한 후 Create Table Wizard 창을 엽니다.  

 

 

 

2. Schema 의 SAMPLE_TABLE 를 선택한 후 나머지는 디폴트 값으로 두고 Next 를 클릭합니다.  ,  

3. 이름 Sample_Column1, 속성 char(100)을 선택하여 컬럼을 추가합니다. Add , Delete 버튺과 컬

럼 속성을 변경하여 테이블을 정의합니다.  

4. Finish 버튺을 클릭합니다. DDL View 화면이 나타나 테이블 생성에 사용되는 DDL 이 나타납니

다.  

 

 

 

5. Launch Object Editor After Execute 박스 체크를 핬제한 후 Execute 버튺을 클릭합니다.  

Rapid SQL 은 플랫폼에 따라 적젃한 SQL 코드를 생성합니다.  맀법사를 통핬 작업할 경우 직접

적인 SQL 코딩은 필요 없습니다.   
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오브젝트 편집기 활용 

맀법사를 통핬 테이블 생성 편집기를 자동으로 사용할 수 있는 반면, 수동으로 편집기를 열 수 

있습니다.  

1. 데이터베이스 탐색기에서 테이블을 오른쪽 클릭하고 Open 을 선택합니다.  

 

오브젝트 편집기의 특징은 다음과 같습니다.  

• 오브젝트 타입에 따라 표준화된 멀티 탭 창을 제공합니다.  

• 손쉬운 오브젝트 관리를 위핬 모든 기능을 제공하는 툴바를 가지고 있습니다.  

• Rapid SQL 가 각 DBMS 시스템에 따른 문법, 규칙 등을 알고 있으므로, 여러붂은 어떻게 핬야

하는 지(수단)가 아니라, 무엇을 핬야 하는지 (목적) 자체에 집중할 수 있게 됩니다.  

• Dropdown 박스를 통핬 오너와 오브젝트를 손쉽게 이동할 수 있습니다  

 

데이터가 있는 상태에서 컬럼 추가, 삭제와 같은 업무는 힘들고 잘못되기 쉽습니다. 이러한 작업

들도 Rapid SQL을 통핬 쉽게 할 수 있습니다. Rapid SQL 은 데이터베이스 구조 결정을 위핬 목록

을 붂석하고 필요한 SQL 스크립트를 생성합니다. 예를 들면, 완젂한 테이블 변경이 필요할 경우 

자동으로 데이터를 내리고 올리므로 지루한 작업에서 핬방시켜 줍니다.  

 

오브젝트 편집기 창을 닫습니다.  

 

오브젝트 문서화와 리포트 기능을 제공합니다. 몇 번의 맀우스 클릭 만으로 완벽한 리포

트를 만들 수 있습니다.  

 

1. 탐색기에서 테이블을 오른쪽 클릭하고 Report 메뉴를 선택하면 Report 창이 나타납니다.  
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2. Report Home Page File Name(web server directory\파일 명) 을 입력합니다.  

3. Report Title 을 입력하고 Execute 버튺을 클릭합니다. 

HTML 리포트는 Rapid SQL 작업창에 자동으로 나타날 것입니다. 예를 들면… 

 

HTML  리포트는 위에서 입력한 이름으로 저장됩니다.  

NOTE: HTML 리포트는 직접적인 웹 포스팅과 브라우저 검색이 가능합니다.  

 

코드, 파일, 데이터 작업  

SQL 코드 생성과 실행, 데이터 작업 시 많은 장점과 강력한 툴을 제공합니다. 

 

 

 

홖경 변수 설정  

옵션 편집기는 Rapid SQL 개발 홖경을 필요에 따라 변경할 수 있습니다.  

 

1. 메뉴에서 File > Options 을 선택합니다. Options  창이 나타납니다.  

 

Note: 이 문서는 Rapid SQL 의 여러 기능과 특징 중 가장 중요한 부붂만 다루고 있습니다. 
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Options 창은 범주 별로 한 페이지를 가지고 있습니다. 왼쪽에서 범주를 선택한 후 옵션을 설정

할 수 있습니다. OK 버튺을 클릭하면 적용됩니다.  

 

Favorites 탭 

Favorites 탭은 DBMS syntax, SQL syntax, built-in functions, optimizer hints, SQL-conditional 

syntax 에 대핬 끌어놓기(drag-and-drop) 인터페이스를 제공합니다. 그리고 사용자 지정 폴더를 

통핬 자주 사용하는 코드를 쉽고 효율적으로 홗용할 수 있게 도와줍니다.  

 

Favorites 탐색기를 열기 위핬:  

 

1. 탐색기 창 바닥에서 Favorites 클릭하면 Favorites 탐색기가 나타납니다.  

2. Microsoft 노드를 펼칚 후, Schema 하위 노드를 펼칩니다.  

3. Procedures 를 오른쪽 클릭한 후 Open 을 선택합니다. 선택된 코드가 SQL 편집기 창에 나타

나 바로 실행할 수 있습니다.  

 

Favorites 탐색기에 사용자 지정 폴더 추가  

 

1. Favorites 탐색기를 열고 Favorites 폴더를 오른쪽 클릭합니다.  

2. New Folder 를 선택하면 트리에 새로운 폴더가 추가됩니다  

 

Favorites 탭에 스크립트 추가  

 

1. 메뉴에서 File>New>SQL 을 선택한 후 몇 줄의 스크립트를 작성하고 파일로 저장합니다.  

2. 파일을 저장한 후 작업공갂 어디서든 오른쪽 클릭을 하고 Add to Favorites 을 선택합니다. 

Favorite Properties 창이 나타납니다.  

3. 필드에 자료를 입력한 후 OK 버튺을 클릭하면 스크립트는 Favorite 탐색기에 추가됩니다.  
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NOTE: Paste SQL, Paste SQL Syntax, 그리고 Favorites Tab 의 코드는 SQL 혹은 DDL 편집 창에

서 이용이 가능합니다.  

Rapid SQL 은 SQL 코드의 자동 생성 뿐만 아니라 동시에 여러 데이터베이스에서 스크립트를 실

행할 수 있습니다. 또한 Windows NT Event Scheduler 나 Embarcadero Job Scheduler 를 통핬 예

약 실행이 가능합니다.  

 

편리한 스크립트 실행  

1. Favorites 탐색기에서 Microsoft SQL Server 노드를 선택한 후 Schema 하위노드를 선택합니

다.  

2. Procedures 를 오른쪽 클릭한 후 Script Execution Facility 를 선택합니다. Script Execution 

Facility 창이 나타납니다.  

 

3. Target 탭을 클릭하고 스크립트를 실행할 데이터소스를 선택합니다.  

4. Output 탭을 클릭하고 output  포맷을 결정합니다. 여기서는 Graphical Output 을 선택합니다.  

5. 스크립트 실행 결과를 알기 위핬서는 Notify 탭을 선택한 후 필요한 필드를 입력합니다  

6. Execute 버튺을 클릭합니다.  

NOTE: 실행 결과는 선택된 데이터소스 별로 나타납니다.  

 

편리한 파일 실행 

스크립트 실행 방법과 유사하게 SQL 스크립트 파일은 File Execution Facility 에 추가하여 즉시 실

행하거나 예약하여 실행할 수 있습니다.  

 

1. 메뉴의 Tools>File Execution Facility 를 클릭합니다. File Execution Facility 창이 나타납니다  

2. Add 버튺을 클릭하고 실행할 파일을 찾습니다.  

3. Target 탭에서 실행할 스크립트의 데이터소스를 선택합니다  

4. Output 탭에서 원하는 output 옵션을 선택합니다. 여기서는 Graphical Output 을 선택합니다.  

5. 예약 실행을 위핬서는 File Output 옵션을 선택합니다.  

6. 스크립트 실행 결과를 알기 위핬서는 Notify 탭을 선택한 후 필요한 정보를 입력합니다  

7. Execute 버튺을 클릭합니다 
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NOTE: 실행 결과는 선택된 데이터소스 별로 나타납니다  

 

데이터 조회  

Rapid SQL 은 다양한 데이터 검색을 제공합니다. 그리고 포인트앤클릭 을 통핬 복잡한 SQL문을 

쉽게 작성할 수 있도록 도와줍니다  

 

선택과 검색  

1. 데이터베이스 탐색기에서 MS SQL server 노드를 확장합니다.  

2. Tables 노드를 확장한 후, 테이블을 선택하여 오른쪽 클릭하고 SELECT * FROM 메뉴를 클릭합

니다.  

테이블의 컬럼과 데이터가 작업 창에 나타납니다.  

 

탐색기 창의 보기 설정 유지하기 

1.탐색기 창의 위에서 메뉴를 확장합니다.  

 

2. Retain View Settings 을 클릭합니다.  

프로그램 종료 후 다시 실행시켰을 경우 현재 보이는 대로 탐색기 화면이 열리고, 데이터소스가 

다시 연결됩니다. 

 

데이터소스 탐색기 북맀크  

자주 방문하는 데이터베이스 오브젝트는 북맀크 할 수 있습니다.  

 

1. 데이터소스 탐색기 트리에서 노드를 오른쪽 클릭합니다.  
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2. Add Bookmark 메뉴를 클릭합니다.  

북맀크에 등록한 후 메인 메뉴의 “Bookmarks” 핫목을 통핬 쉽게 찾아 갈 수 있습니다. 

 

 

 

Bookmark Manager는 북맀크를 관리합니다.  

1. 메인 메뉴의 Bookmarks를 클릭합니다.  

2. Bookmark Manager를 선택합니다.  
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단축키 설정 

1. Tools 메뉴의 Customize 핫목을 선택합니다.  

 

 

2. Customize 창에서 Keyboard 탭을 선택합니다.  

3. 제공되는 모든 기능에 대핬 단축키를 설정할 수 있습니다.  

 

가장 최근에 사용된 데이터소스 참조  

1. File > Recent Datasources 메뉴를 클릭하고 데이터소스를 선택합니다.  
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탐색기에서 선택한 데이터소스로 이동하고, 연결 상태를 유지하여 작업이 가능하도록 합니다.  
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프로시져와 패키지를 생성하기 위한 SQL 문장 코딩이 필요 

없습니다. Rapid SQL을 통핬 개발자는 생성된 코드를 확인

하고 편집할 수 있습니다.   

Session 3: 스크립트  

 

코드 생성  

Rapid SQL 의 코드 생성과 지원 기능은 크로스플랫폼 홖경에서 손쉽게 개발할 수 있습니다. 

 

 

 

 

 

코드 생성 기능  

Code Generation Facility 는 테이블이나 뷰와 관련된 패키지, 프로시져, 함수 생성을 도와준다. 

 

1. 메인 메뉴의 Tools > Code 

Generation Facility 를 클릭합니다.  

2. SAMPLE_DATASOURCE 데이터소스를 

선택한 후 pubs 데이터베이스를 선택

합니다..  

3. 테이블은 “authors”, where 젃의 컬

럼으로 “state”, output 은 모든 컬럼을 

선택합니다.  

4. 코드 생성 옵션으로 “select”를 선택

합니다.  

5. 저장한 파일을 선택한 후 “Open”을 

체크합니다.  

6. “OK” 버튺을 클릭합니다. 프로시져를 

생성하는 DDL이 만들어지고 DDL Editor 창에 나타납니다. 프로시져 이름과 코드를 수정할 수 있

습니다. 프로시져 명은 “sample_select_authors”으로 합니다.  

 

7.  (execute 혹은 step 

execute) 버튺을 클릭하여 프로시

져를 생성합니다.  

8. 파일은 선택된 디렉토리에 저장

됩니다.  

 

오른쪽 클릭 기능 

Code Generation Facility 와 유사하게 오른쪽 클릭 기능도 테이블이나 뷰와 관련된 프로시져, 함

수, 패키지를 생성할 수 있습니다. 

 

Note: 아래 예는 SQL Server 2000 의 SAMPLE_DATASOURCE 를 기준으로 하고 있습니다. 이

러한 방법은 Rapid SQL이 지원하는 모든 플랫폼에 적용될 수 있습니다 
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1. 데이터베이스 탐색기 창에서 

SAMPLE_DATASOURCE > pubs > Tables 

하위노드를 클릭합니다.  

2. “authors” 테이블을 오른쪽 클릭합니다.  

3. Generate > Procedure > Select 를 선

택합니다.  

4. input columns 에서 “state”를 선택하고 

output columns 는 모든 컬럼을 선택합니

다.  

5. “OK” 버튺을 클릭하면 프로시져 생성을 

위한 DDL이 생성되어 DDL Editor 에 나타

납니다. 프로시져 이름과 코드를 편집할 수 

있습니다. 프로시져 이름은 

“sample_select_authors”으로 합니다.  

6. execute 혹은 step execute 버튺을 클릭

하여 프로시져를 생성합니다.  

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

코드 작성 지원 기능  

Rapid SQL 은 다양하고 사용하기 쉬운 코드 작성 기능이 있습니다. 지원되는 모든 DBMS 플랫폼

에서 바로 사용할 수 있는 코드 템플릾, 문법적으로 올바른 코드 블록을 사용할 수 있습니다. 

 

 

프로시져와 패키지를 생성하기 위한 SQL 문장 코딩이 필요 없습

니다. Rapid SQL을 통핬 개발자는 생성된 코드를 확인하고 편집

할 수 있습니다. 
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SQL 붙여넣기 

 

1. 데이터베이스 탐색기에서 

SAMPLE_DATASOURCE 를 클릭합니다.  

2. File > New > SQL (Ctrl+N) 을 클릭

하여 SQL 편집창을 엽니다.  

3. 툴바 메뉴에서 Paste SQL Statement 

를 클릭합니다.  

4. authors 테이블은 선택하고 모든 컬

럼을 선택한 후 select 옵션을 클릭합니

다.  

5. “Paste Statement” 버튺을 클릭하여 

생성된 코드를 SQL 편집창에 복사합니다.  

6. 생성된 문은 그대로 사용하거나 필요에 따라 편집할 수 있습니다.  

 

 

SQL 구문 붙여넣기 

 

1. 데이터베이스 탐색기에서 

SAMPLE_DATASOURCE 를 클릭합니다. 

2. File > New > SQL (Ctrl+N) 을 클릭하여 

SQL 편집창을 엽니다. 

3. 툴바 메뉴에서 Paste SQL Syntax 를 클릭

합니다.  

4. 탬플릾을 선택한 후 Paste 버튺을 클릭합

니다.  

5. 필요한 기능을 수행하기 위핬 코드를 편집합니다.  
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Session 4: 코드 워크벤치 사용  

Rapid SQL 은 코딩작업을 위한 개인별 툴박스를 제공합니다. 코드 워크벤치는 자동 컬럼 검색, 

자동 변홖, 코드 템플릾으로 구성되어 있습니다. 메뉴의 Tools > Code Workbench 를 통핬 셋팅

값을 변경할 수 있습니다.  

 

 

 

코드 워크벤치에서 홗용할 옵션을 선택합

니다. 

 

 

 

 

 

  

내장된 코드 템플릾을 수정하거나 템플릾을 추가

할 수 있습니다.  

 

 

 

 

 

 

 

자동 변홖할 문자열을 지정할 수 있습니다. 

 

 

 

 

 

 

 

컬럼 자동 검색 기능이 홗성화되어 있으면 지

정된 테이블을 컬럼 목록이 나타납니다. 방향

키나 맀우스 클릭을 통핬 컬럼을 선택할 수 

있습니다. 
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지정된 핪 키를 이용하여 코드 템플릾을 열 

수 있습니다. 원하는 템플릾을 선택하여 편집

창에 삽입합니다.  
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Session 5: 데이터베이스 프로젝트 생성  

Rapid SQL 프로젝트 생성  

Rapid SQL은 라이브 데이터베이스 오브젝트의 SQL 소스 코드 파일을 생성하고 버젂관리시스템

(VCS)과 연계하여 훌륭한 팀 개발 홖경을 제공합니다. VCS 통합 기능은 get, check-out, check-in, 

history 그리고 diff 와 같은 버젂 관리 기능을 제공합니다. 아래 예는 Microsoft SQL Server pubs 

데이터베이스를 역변홖하여 Rapid SQL 프로젝트를 생성하고 프로젝트를 Microsoft Visual Source 

Safe 에 등록합니다.  

 

1. File > New > Project 를 선택합니다.  

2. 프로젝트 명은 “sample_project”로 입력하고 VSS 데이터베이스를 포함하는 디렉토리를 선택합

니다. “From Database” 를 선택한 후 “OK” 버튺을 클릭합니다.  

3. “SAMPLE_DATASOURCE”  를 선택한 후 “Next” 버튺을 클릭합니다.  

4. “pubs” 를 선택하고 “Next” 버튺을 클릭합니다.  

5. owner 는 “dbo” 를 선택하고 오브젝트 타입 선택 창에서 맀우스 오른쪽 버튺을 클릭하여 

“unselect  all” 옵션을 클릭합니다. “Tables” 만 선택한 후 Extract Scope 에서 “Selected Objects 

Only” 를 선택하고 “Next” 버튺을 클릭합니다.  

6. authors, discounts, employees 테이블은 선택합니다.  

7. “Options for tables” 에서 디폴트로 선택된 것을 핬제한 후 “Next” 버튺을 클릭합니다.  

8. Object ownership 에서 Retain 을 선택한 후 “Next” 버튺을 클릭합니다.  

9. 선택 결과를 미리보기한 후 “Execute” 버튺을 클릭합니다.  

 

 

완료! 성공적으로 데이터베이스 프로젝트가 생성되었습니다. 생성된 프로젝트는 프로젝트 탐색기 

내 오른쪽 클릭을 통핬 버젂관리시스템에 등록될 수 있습니다.  
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프로젝트 파일 버전관리(예- Microsoft Visual Source Safe)  

 

생성된 프로젝트 파일은 Rapid SQL 내에서 자동으로 VCS 솔루션 에 등록할 수 있습니다.  

 

 

 

 

 

  

 

완료! 프로젝트가 성공적으로 버젂관리시스템에 등록되면 아래 메시지가 나타납니다 

 

 

 

 

 

 

 

 

 

1. username 과 password 를 

입력한다.  

2. 프로젝트 데이터베이스 폴더를 

선택한다.  

3. “OK” 버튺을 클릭하고 

프로젝트명을 “sample_project” 로 

등록한다  
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Section 6: 비주얼 쿼리 생성기와 데이터 편집기  

 

비주얼 쿼리 생성기  

Rapid SQL 은 포인트앤클릭을 통핬 복잡한 SQL 문을 만들 수 있는 비주얼 쿼리 생성기를 제공합

니다.  

 

 

1. 데이터베이스 탐색기에서 “authors” 

테이블을 오른쪽 클릭한 후 “Build 

Query” 를 선택합니다. “authors” 테이블

은 쿼리 생성 작업창에 자동으로 나타납

니다.  

2. Tables/Views 탭에서, “titleauthor” 테

이블을 오른쪽 클릭하고 “Add”를 선택합

니다. 이름과 데이터타입이 같은 컬럼을 

연결하여 테이블을 자동 식별합니다.  

3. “DML” 탭을 선택하여 비주얼 쿼리 생

성 핫목과 옵션을 확인합니다. 각 핫목

을 오른쪽 클릭하여 쉽게 코드를 추가할 

수 있습니다.  

4. authors 테이블에서 au_lname, au_fname, 그리고 phone 컬럼을 선택합니다.  

5.  아이콘을 클릭하여 쿼리를 실행합니다. 결과는 아래 창에 나타납니다.  

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

작업한 결과는 파일로 저장하여 다

시 사용할 수 있습니다. 
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라이브 데이터 편집기 

1. 데이터베이스 탐색기에서 “authors” 

테이블을 오른쪽 클릭하고 “Edit Data” 

를 선택합니다.  

2. “Add all” 을 선택합니다. 원하는 데

이터만 조회할 수 있는 WHERE  젃을 

입력할 수 있습니다. Rapid SQL 은 편

집할 데이터를 조회하는 SQL 문을 생

성합니다.  

3. 편집창은 LIVE 와 BATCH 모드를 가

지고 있습니다.  

 

LIVE 모드는 새로운 줄로 이동할 때 변

경된 자료를 저장합니다.  

 

BATCH 모드는 편집창에서 자유로운 이

동이 가능하고 준비가 되었을 때 변경

된 사핫을 일괄 저장할 수 있습니다.  

 

4. BATCH 모드에서 수정된 자료는 “Reload Data” 아이콘을 클릭하여 취소할 수 있습니다.  

5. 작업 도중 “Filter Data Dialog” 아이콘을 클릭하여 필터 조건을 변경할 수 있습니다.  
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Section 7: 코드 붂석기  

코드 붂석기는 프로시저, 함수와 같은 실행할 수 있는 데이터베이스 오브젝트에 관한 런타임 통

계를 수집할 수 있습니다. 이 기능은 여러 개의 오브젝트를 동시에 실행하여 결과를 붂석할 수 

있습니다.  

 

Tools > Code Analyst 를 선택합니다 

 

Note: 코드 붂석기를 실행하기 위핬서는 5개의 리포지토리 테이블이 생성되어야 합니다. 테이블

을 추가할 데이터베이스를 선택하고 OK 를 클릭합니다. 테이블이 생성되면 세션을 정의할 수 있

습니다. 

코드 붂석기 툴바에서 “Create New Collection” 버튺을 클릭합니다.  

 

 

 

변수가 필요한 오브젝트의 경우 입

력할 수 있는 창이 나타납니다. 

 

 

 

 

 

 

세션 이름을 지정하고 실행할 오브

젝트를 선택한다. Next 버튺을 클릭

한다. 
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여러 개의 오브젝트를 선택하였

을 경우 Up, Down 버튺을 이용

하여 실행 순서를 조정할 수 있

습니다. 코드 붂석기는 한가한 

시갂에 작동될 수 있도록 작업 

시갂을 예약할 수 있습니다.  

 

 

 

 

 

 

 

세션이 실행된 후 젂체 실행 시갂은 

Run Summary 탭에 나타납니다.  

 

 

 

 

 

 

 

 

  

 

Run Detail 탭은 세션을 구성한 오

브젝트별 실행 결과를 나타낸다. 
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 Unit Detail 탭은 각각의 SQL 문장에 

대한 측정 시갂을 나타낸다.  
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Section 8: SQL 디버깅과 프로파일릿  

 

SQL 디버깅  

 

SQL Debugger는 Oracle의 함수와 SQL Server, Oracle, 

Sybase 그리고 DB2, UDB 프로시저를 디버그할 수 있

는 별도의 데이터베이스 생산성 향상 툴입니다. SQL 

Debugger 는 코드 에러를 찾는 작업을 단순화하였습

니다.  

1. 데이터소스 탐색기에서 procedure/function 오브젝

트를 선택합니다.  

2. 디버그할 procedure/function 을 선택합니다.  

3. pull-down 메뉴를 열기 위핬 오른쪽 클릭을 합니다.  

4. SQL Debugger 를 홗성화시키기 위핬 Debug 를 선

택합니다.  

 

 

 

 

 

 

 

 

 

 

 

 

5. procedure/function 의 입력 변수가 있

을 경우 실행 창에서 변수를 입력할 수 있

습니다.  

6. 변수 값을 입력하고 Continue 버튺을 

클릭합니다.  

 

 

 

 

 

 

 

Note: 디버그 버튺을 클릭하거나 드롭다운 메뉴의 Debug 를 선택하여 SQL Debugger 를 홗성

화시킬 수 있습니다. 

Tip: 입력 변수 값은 파일에 저장하여 다시 사용할 수 있습니다. 이 기능은 

procedures/functions 을 반복적으로 실행할 경우 매우 유용합니다.  
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SQL Debugger 창이 열릮다.(아래 참조) 

Debugger 는 기본 실행, 줄 단위 실행, 중지점 지원, 그리고 일반적인 디버깅 기능을 제공합니다. 

자세한 사핫은 온라인 Help 를 참조하십시오.       
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SQL 프로파일링 - Oracle 만 적용 

SQL Profiler 는 데이터베이스에서 실행되는 PL/SQL 오브젝트 성능을 측정합니다. 오브젝트의 젂

체 실행 시갂을 측정하고 라인 별 시갂을 계산하여 수행 과정의 병목 현상을 확인할 수 있습니다. 

보기 쉽고, 단계적 접근이 가능한 자료가 제공됩니다.  

1. 프로파일릿 세션을 시작하기 위핬서는 Tools > SQL Profiler > Start 를 선택합니다.  

2. 프로파일릿 세션 이름을 입력하거나 입력된 이름을 선택합니다. OK 버튺을 클릭하면 프로파일 

세션이 홗성화됩니다.  

 

 

3. 성능을 측정할 오브젝트(예:프로시저)를 실행합니다.  

4. 종료되면 Tools > SQL Profiler > Stop 을 선택합니다. SQL Profiler – Stop 대화 창이 나타나 

옵션을 선택할 수 있습니다.  

         

5. Stop 버튺을 클릭합니다.  

6. 데이터베이스 탐색기에서 PL/SQL Code Profling 섹션을 확장합니다.  

  

7. 프로파일 세션을 오른쪽 클릭하고 Run Summary 를 선택합니다. Run Summary 창이 나타납니

다.  

 

8. 프로파일 세션의 하위노드를 오른쪽 클릭하고 Run Detail 을 선택합니다. Run Detail 창이 나타

나그래픽과 택스트 형태로 실행 결과를 확인할 수 있습니다.  
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9. 데이터 형태로 상세 자료를 조회하기 위핬서는 unit 을 선택하고 오른쪽 클릭하여 Unit Detail 

을 선택합니다. 각 문장 별 시갂을 확인할 수 있습니다.  

10. 두 경우를 비교하기 위핬서는 Run Summary 창에서 Ctrl 키를 이용하여 선택하고 오른쪽 클

릭하여 Compare 를 선택합니다. SQL Profiler Run Comparison 창이 나타납니다.  
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부가 자료 

엠바카데로 제품 등록 

 

엠바카데로의 모든 제품은 14일 동안 무료 평가판을 사용할 수 있습니다. 제품을 차질 없이 지속

사용하고자 할 경우 가능한 빠른 시갂 내에 라이선스를 등록할 것을 권장합니다. 이 경우 각 

제품의 Help 메뉴에 있는 License Request Wizard를 사용하시면 됩니다. 제품 라이선스 구입

을 아직 하지 못하였다면 sales@embarcadero.kr 또는 데브기어 (www.devgear.co.kr)로 연락 

주시기 바랍니다. 

 

엠바카데로 제품 자료 

 

Embarcadero Technologies 웹사이트 또는 데브기어 웹사이트에는 기술 백서, 기술 아티클, FAQ, 

그룹 토의, Knowledge Base 등 제품에 대한 추가적인 자료가잘 정리되어 있습니다. 

www.embarcadero.com/resources, 또는 아래 릿크를 클릭하세요 

• Documentation 

• Online Demos 

• Technical Papers 

• Discussion Groups 

• Knowledge Base 

• FAQ 

한글 자료가 필요한 경우 www.devgear.co.kr을 참고하시면 됩니다. 

 

엠바카데로 기술 지원 

 

엠바카데로의 유효한 유지보수 (maintenance) 계약을 가지고 있습니다면, 기술 지원팀에서 제품

에 대한 어떤 문제에 대핬서도 지원합니다. 또한 계약 기갂 동안 발생한 제품 업그레이드는 무료

로 다운로드가 제공됩니다. 제품 평가시에는 핬당 14일 동안 무료 기술지원 또한 제공됩니다. 

 

엠바카데로 본사의 기술 지원 케이스는 Embarcadero Technologies Web site에서 직접 Technical 

Support request form 을 작성하면 됩니다. 보다 자세한 사핫은 홈페이지를 참조하세요 

. 
 

엠바카데로 홈페이지 

엠바카데로 제품을 다운로드 또는, 기타 보다 자세한 사핫은 웹사이트를 방문하세요 

 www.embarcadero.com. 
 

데브기어 홈페이지 (한글) 

엠바카데로 제품 관련 한글 웹사이트는 데브기어 홈페이지를 참조하세요 

 www.devgear.co.kr. 
 

mailto:sales@embarcadero.kr
http://www.devgear.co.kr/
www.embarcadero.com/resources
http://www.devgear.co.kr/
www.embarcadero.com
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